SSL Error with Bing Maps Example

Apr 6, 2010 at 7:17 AM

This is a great way to connect SharePoint list data with Bing Maps.  However, I’ve tried to reverse engineer the Bing Maps example on sharejpoint.com and I’m running into an SSL error when using this on a SharePoint site using SSL.  I have it setup correctly; however, I get a message:  “Do you want to view only the webpage content that was delivered securely?”

If I select No, everything works as expected.  If I select Yes, I can’t see the map.

I can’t locate anything obvious that is referencing http (nor can IEWatch).  I changed the URLs to Bing and Google from http to https and it didn’t make a difference.

Idea -- could there be a way to include the Bing Map API key and the environment URL (staging vs. production) in the options when you edit the web part?

Many thanks,
Mike

Coordinator
Apr 9, 2010 at 6:34 AM

I am not sure.  I'll look into it when I have a chance.  In general, jPart plugin code can be written by any developer.  It is much like the jQuery plugins.  So, problems with the jQuery plugin should be directed to the developer.  Problems with jQuery would be directed to the jQuery team. 

The jPoint contributor team will concentrate on making improvements to the core.  Anyone on the team or anybody else reading these forums can help because it will only make the SharePoint scripting community better.  One idea you've made me think of is the jPoint team can work on the description part of the jPart (with the yellow background) that shows up when you are editing a SharePoint page.  It can be more clear how to communicate to the developer for questions.  For now, though, let's continue to use the jPoint.Codeplex.com discussion list.  I just thought I'd make a point that there is a difference between core code and [other's] plugin code.

-Will

 

Mar 10, 2011 at 1:37 PM

I changed the following in the jpart.binglist.js

On line 10 change the url in the jp.include

the whole line should be..

----------------------

jp.include(['https://dev.virtualearch.net/mapcontrol/mapcontrol.ashx?v=6.1&s=1']);

----------------------

Now SSL works without the prompt.

Biran



Coordinator
Mar 11, 2011 at 12:32 AM
Thanks, Biran. To best make this https or http friendly, the protocol can be left out. The jPoint team has updated jpart.binglist.js to the following:


This article describes other common javascript methods that cause mixed content warnings to be displayed and refers to the use of the double slash // as a solution. http://blog.httpwatch.com/2009/09/17/even-more-problems-with-the-ie-8-mixed-content-warning/

Thanks again,
Will

On Thu, Mar 10, 2011 at 8:37 AM, bbelcher <notifications@codeplex.com> wrote:

From: bbelcher

I changed the following in the jpart.binglist.js

On line 10 change the url in the jp.include

the whole line should be..

----------------------

jp.include(['https://dev.virtualearch.net/mapcontrol/mapcontrol.ashx?v=6.1&s=1']);

----------------------

Now SSL works without the prompt.

Biran



Read the full discussion online.

To add a post to this discussion, reply to this email (jPoint@discussions.codeplex.com)

To start a new discussion for this project, email jPoint@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Mar 11, 2011 at 1:10 AM

Hello Will,

Removing the protocal had no effect, but adding &s=1 to the URL did fix it.

e.g. No Security errors after I used the following:

jP.include(['https://ecn.dev.virtualearth.net/mapcontrol/mapcontrol.ashx?v=6.2&mkt=en-us&s=1']);

Best regards,
Mike

Coordinator
Mar 11, 2011 at 1:33 AM
Mike,

Thanks, the jPart has correctly been updated.

-Will

On Thu, Mar 10, 2011 at 8:10 PM, mchova01 <notifications@codeplex.com> wrote:

From: mchova01

Hello Will,

Removing the protocal had no effect, but adding &s=1 to the URL did fix it.

e.g. No Security errors after I used the following:

jP.include(['https://ecn.dev.virtualearth.net/mapcontrol/mapcontrol.ashx?v=6.2&mkt=en-us&s=1']);

Best regards,
Mike

Read the full discussion online.

To add a post to this discussion, reply to this email (jPoint@discussions.codeplex.com)

To start a new discussion for this project, email jPoint@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com